Mengaktifkan .htaccess Apache di Linux Ubuntu


Terkadang kita mengalami masalah ketika mengakses website atau aplikasi web kita yang baru di upload di server linux muncul pesan Not Found. mungkin hal tersebut dikarenakan fitur .htaccess di server apache linux belum di aktifkan, dan  .htaccess (hypertext access) file adalah sebuah directory-level configuration file, yang dapat digunakan pada beberapa jenis web server, salah satunya ialah Apache. File .htaccess sendiri biasa digunakan untuk berbagai keperluan seperti mengalihkan URL (URL Redirection), pemendekan URL (URL Shortening), Access Security Control (untuk beberapa halaman web dan file yang berbeda), dan berbegai penggunaan lainnya.


Langsung saja berikut ini tutotial untuk mengaktifkan .htaccess Apache server di ubuntu sever 16.04 LTS, disini saya menggunakan linux ubuntu server dan apache sebagai webservernya. untuk teman-teman yang menggunakan distro linux lainnya juga bisa mengikuti tutorial ini.

Cara Mengaktifkan .htaccess apache di linux ubuntu 16.04 LTS

1. Buka file apache2.conf dengan mengektikkan perintah di bawah pada terminal anda :
  sudo nano /etc/apache2/apache2.conf

2. Cari line/baris dengan script "AccessFileName .htaccess", apabila ada tanda (#) didepannya silahkan dihapus.

3.  Kemudian temukan line /baris dengan script seperti dibawah ini:
<Directory /var/www/>
     Options Indexes FollowSymLinks
     AllowOverride None
     Require all granted
</Directory> 

ganti " None " ke " All "
AllowOverride All

4. Selanjutnya, coba check pada file 000-default.conf  pada " /etc/apache2/sites-available/000-default.conf ", dengan memasukkan perintah :
sudo nano /etc/apache2/sites-available/000-default.conf

5. Kemudian lakukan hal yang sama seperti pada langkah ke tiga pada file 000-default.conf tersebut.
(ket : Langkah 4 dan 5 dilakukan tergantung pada versi Ubuntu yang anda gunakan, pada Ubutnu 16.04 seperti yang saya gunakan sendiri tidak perlu melakukan langkah nomor 4 dan 5 ).

6. Selanjutnya aktifkan ModRewrite dengan mengetikkan perintah :
sudo a2enmod rewrite

7. Terakhir restart service apache dengan perintah :
sudo service apache2 restart

8. Dan silakan coba gunakan .htaccess pada aplikasi web di web server anda.

Demikianlah tutorial mengenai cara mengaktifkan .htaccess Apache pada Ubuntu.  Semoga tutorial kali ini dapat bermanfaat bagi anda yang membutuhkan.

Apabila anda memiliki pertanyaan, kritik, atau saran, silakan untuk jangan ragu menyampaikannya melalui kolom komentar di bawah.

Terimakasih 

Download Sourcode PULSAQU - Aplikasi Untuk mencatat Transaksi Pulsa Dengan Codeigniter 3 dan Ion Auth

Sebelumnya saya telah membuat Aplikasi untuk Managemen IT Asset yang siap digunakan untuk mengelola IT Asset dengan mudah yaitu SIMITA ( Sistem Informasi Management IT Asset).



Dan kali ini saya akan membagikan sourcode aplikasi untuk mencatat transaksi pulsa baik itu pembelian pulsa secara tunai maupun kredit. Aplikasi cocok digunakan oleh penjual pulsa mobile, atau yang biasa kita beli pulsa ke temen via chating dan bayarnya belakangan, dan si penjual akan mencatat transaksi tersebut di aplikasi ini jadi bisa dilihat siapa saja yang minta transfer pulsa dan juga status pembayaran nya lunas atau hutang dimana saja dengan mudah dan cepat. 

Fitur Aplikasi Pulsaqu :
  1. Menggunakan Framework CI 3.x
  2. Menggunakan Library Ion Auth
  3. Datatables Server Side
  4. Multi User dan Multi Level
  5. Template Admin LTE
  6. Halaman Dashboard 
  7. Halaman Menu Master ( Pelanggan, Nominal & Harga pulsa)
  8. Halaman Menu Transaksi (Transaksi lunas, Hutang, All Transaksi)
  9. Menu Seting Untuk Level Administrator  
  10. Add Menu dinamis 
Halaman Dashboard


Tambah Transaksi

List Transaksi

Daftar Menu dinamis

Dan berikut untuk link download nya Pulsaqu , untuk link demonya http://pulsaqu.nexterweb.id/



SIMITA (Sistem Informasi Management IT Asset) - aplikasi inventory laptop,komputer,printer dan network device

SIMITA ( Sistem Informasi Management IT Asset ) atau bisa juga di sebut IT Asset Management. dibuat berdasarkan inisiatif saya sebagai Staff Network Administrator & Hadware di dept. ICT suatu perusahaan. Dimana saya mengelola banyak inventory perangkat-perangkat komputer diantaranya : Laptop, PC, Printer, Network Device, CCTV dan lainya. Dalam mengelola inventory komputer yang banyak, dibutuhkan suatu aplikasi yang bisa mencatat semua detail inventory tersebut dari awal pembelian, terus siapa penggunanya, berapa kali komputer tersebut di perbaiki, berapa kali ganti sparetpart, biaya perbaikan berapa, berapa kali mutasi pengguna dan mengetahui total semua inventory yang di gunakan saat ini serta berapa jumlah inventory yang sudah rusak.

Untuk mengetahui detail fiture apa saja yang ada di aplikasi SIMITA ini langsung saja saya jelaskan di bawah ini:
  1. Menu aplikasi yang dinamis 
  2. Multi user dan multi level ( administrator , admin )
  3. Multi group (bisa di gunakan untuk banyak kantor cabang dengan satu pusat data)
  4. Ticketing (form halaman untuk melakukan permintaan perbaikan komputer ke bagian IT)
  5. Master data ( master barang, departemen, pengguna, supplier/pemasok barang )
  6. Transaksi barang masuk (pencatatan barang masuk di dept. IT seperti laptop, komputer, dll)
  7. Transaksi barang keluar (mutasi barang dari dept. IT ke user pengguna)
  8. Cetak transaksi barang keluar
  9. Stok barang/ Sparepart (mengetahui stok perangkat komputer dan detail mutasi barang tersebut)
  10. Cetak kartu stok barang (detail dari barang masuk dan keluar)
  11. Inventory (laptop, komputer, monitor, printer, network device & device lainya)
  12. Export data inventory ke format  Excel dan PDF
  13. Maintenance/ Perbaikan (detail perbaikan dari semua inventory bisa di ketahui)
  14. Mutasi pengguna inventory (setiap inventory bisa di lihat mutasi penggunanya)
  15. Cetak mutasi pengguna inventory

Aplikasi ini bagi menjadi dua fungsi yaitu frondend dan backend aplikasi

#FrondEnd

Frondend program ini yaitu tampilan pertama ketika mengakses aplikasi ini. ditunjukan untuk user pengguna inventory komputer untuk layanan permohonan perbaikan, dengan aplikasi ini maka admin pengelola inventory akan lebih mudah untuk mengetahui inventory mana yang perlu segera di perbaiki dan bagian kantor mana inventory komputer tersebut digunakan.   

dari gambar diatas akan terlihat logo kantor cabang yang ada di peruhasan tersebut dalam slide menu. anda bisa mengurangi atau menambah kantor cabang tersebut lewat control panel backend.

  
Form ticket permohonan perbaikan inventory, di isi oleh user pengguna inventory tersebut.


Ticket yang telah di buat oleh user kemudian di respon oleh admin dari menu control panel administrator. 


user bisa mengetahui respon admin bagian IT, terkait permohonan nya. 

#BackEnd

Backend program atau bisa di sebut juga dengan admin control panel program. untuk masuk ke lagin backend program anda tinggal klik login kemudian isikan user dan passwordnya dengan benar. backend program inilah yang akan mengelola seluruh inventory komputer seperti yang sudah di jelaskan di atas fiture-fiture program apa saja yang ada. 


Halaman Login

setipa user akan bisa berbeda-beda group, tergantung awal pembuatan user, dan group ini menandakan bahwa user tersebut pengelola inventory di kantor cabang mana. karena group disini menandakan kantor cabang.


Menu master - barang, tampilan data barang.

Menu master terdiri dari master barang, supplier, pengguna, dan departemen.


Menu master - departemen, tampilan menggunakan treeview


view daftar inventory-laptop


detail dari salah satu inventory laptop

daftar perbaikan laptop


cetak daftar perbaikan laptop


cetak mutasi inventory 


transaksi barang masuk


daftar stok barang.


cetak nota serah terima barang/ inventory baru 

demikianlah kurang lebihnya penjelasan dari aplikasi sistem informasi management IT asset, dan untuk lebih detailnya anda bisa langsung kunjungi di link demo aplikasinya http://itasset.nexterweb.id/ , user dan password : andrianext


untuk mendapatkan sourcode dari aplikasi tersebut anda bisa kontak saya dengan mengisi form kontak di blog ini, atau melalui WA : 089637079030 hanya dengan donasi Rp 200.000,-

Aplikasi ini bisa langsung di implementasikan di perusahaan anda, dan sudah di gunakan di salah satu perusahaan, lebih dari 2 thn dengan skala jumlah inventory lebih dari 500 unit PC dan laptop, yang tersebar di beberapa kantor cabang.  








Membuat Project SMS Gateway Integrasi dengan Database Koperasi

Setelah sebelumnya saya shared cara membuat sms gateway dengan gamu di windows . kali ini hasil dari project sms gateway yang saya bangung menggunakan engine gammu dan terintegrasi dengan sistem / database Koperasi.



System & Hardware yang di gunakan :
  • OS  : Linux Ubuntu Server
  • Engine Sms : Gammu versi 13
  • Modem : Wavecome M1 306B Q2406B USB
Detail Aplikasi SMS Gateway  :
  • Web Base
  • Framework CI 3
  • AdminLTE theme
  • Library Ion Auth
  • Multi Level login ( administrator & admin )
  • Kirim Pesan satu nomor tujuan
  • Kirim Pesan group
  • Kirim Pesan group dengan filter tertentu
  • Pendaftaran Nomor anggota koperasi
  • Autoreply tagihan anggota
  • Autoreply simpanan anggota
  • Autoreply cek point belanja member
  • Export excel
  • dll
Halaman login


Halaman dashboard


Halaman Kirim Pesan 


Halaman Kirim Pesan Group


Halaman Pesan Masuk

Halaman Pesan Terkirim


Halaman Tambah phonebook


Demikian Sebagian besan hasil Screenshot dari aplikasi sms gateway yang saya buat, dan aplikasi tersebut mungkin jauh dari kata sempurna, yang terpenting sudah sesuai dengan permintaan client. dan apikasi ini bisa di custome untuk di integrasikan dengan system lainnya.







Mengetahui Ukuran File atau Kapasitas Direktori Disk di linux, melalui Terminal Command

Untuk mengetahui ukuran file atau folder direktori di sistem operasi windows kita bisa melakukannya dengan cara klik kanan properties, tetapi berbeda dengan di linux berbasis text. untuk linux berbasis text dengan cara mengetikan command du (disk Usage) dan df dengan berbagai macam variasi sesui kebutuhan informasi yang akan di tampilkan. Command du digunakan untuk mengetahui ukuran file atau direktori, sedangkan command df digunakan untuk mengetahui total kapasitas harddisk, kapasitas harddisk yang tersisa serta kapasitas harddisk yang sudah digunakan.


Cara Mengetahui Ukuran File dan Direktori Linux

Command du (disk usage) adalah merupakan perintah standar Linux / Unix yang digunakan untuk memeriksa informasi dari penggunaan disk pada file maupun direktori Linux / Unix. Command du ini memiliki banyak pilihan parameter yang dapat anda sesuaikan dengan kebutuhan.
Berikut adalah macam-macam parameter command du :

# Untuk mengetahui ukuran file, direktori serta subdirektori tertentu :
du /var/www

# Tambahkan opsi -h (human readable) untuk menampilkan ukuran file, direktori dan subdirektori dengan menggunakan B (Bytes), K (Kilobytes), M (Megabytes), G (Gigabytes), T (Terabytes) dan seterusnya.
du –h /var/www

# Untuk mengetahui total ukuran direktori tertentu, silahkan tambahkan opsi -s seperti berikut :
du –sh /var/www

# Gunakan opsi -a untuk mengetahui ukuran seluruh file dan direktori yang ada :
du –a /var/www

# Jika ingin menampilkan informasi ukuran file atau direktori dalam kilobytes, maka gunakan opsi -k, sedangkan jika ingin menampilkan ukuran file atau direktori dalam megabytes, maka gunakan opsi -m. Anda bisa menambahkan opsi -h untuk membuat tampilannya mudah dipahami (human readable).
du –k /var/wwwdu –m /var/www

# Untuk mengetahui informasi jumlah total ukuran keseluruhan file dan subdirektori pada direktori yang dicek, silahkan tambahkan opsi -c :
du –ch /var/www

# Apabila anda ingin mengetahui ukuran semua file dan sub direktori yang ada, kecuali file dengan format tertentu misalnya format .html, maka anda harus menambahkan opsi -–exclude disertai dengan format file yang tidak ingin anda ketahui (.html) seperti berikut ini :
du -ah --exclude="*.html" /var/www

# Bagi anda yang ingin juga menyertakan tanggal modifikasi atau pembuatan file dan direktori / subdirektori, silahkan anda tambahkan opsi –time. Seperti contoh berikut :
du -ha --time /var/www

Cara Mengetahui Kapasitas Harddisk Linux

Tidak jauh berbeda dengan du (disk usage), df (disk filesystem) juga memiliki variasi parameter command yang sangat mirip. Jika anda sudah memahami apa saja dan digunakan untuk apa saja variasi parameter command du, maka anda akan bisa memahami juga apa saja dan untuk apa saja variasi dari command df.
# Gunakan command df untuk mendapatkan informasi nama device, total ukuran disk, disk yang sudah digunakan, disk yang masih tersedia, persentasi penggunaan disk dan lokasi penempatan disk.
df

# Tambahkan opsi -h untuk mempermudah anda dalam memahami tampilan informasi yang muncul di layar console :
df -h

# Untuk opsi lainnya, silahkan anda lihat dengan mengetikan opsi –help :
df –help

Dengan mengetikan opsi tersebut, anda akan mengetahui opsi apa saja yang bisa anda gunakan untuk mengetahui kapasitas harddisk, seberapa banyak harddisk yang sudah dipakai dan seberapa banyak harddisk yang masih tersisa dengan ragam opsi, seperti opsi -i untuk menampilkan informasi inode, opsi -a untuk menyertakan informasi dummy file system dan lain sebagainya.

Demikianlah cara mengetahui kapasitas harddisk, ukuran harddisk yang digunakan dan harddisk yang tersedia serta cara mengetahui ukuran atau size file dan direktori pada sistem operasi linux.


Membuat SMS Gateway dengan Gammu, Php dan Mysql di Windows

SMS Gateway adalah sebuah gerbang yang menghubungkan komputer dengan client melalui sms. jadi sms gateway bisa diartikan juga mengirim sms melalui komputer / tidak lagi melalui handphone /hp. Kelebihan dari sms gateway yaitu kita bisa sms ke banyak nomer dengan mudah memalui komputer, atau mengirim sms otomastis dari sebuah sistem / aplikasi misal: sms informasi absen siswa ke orang tua siswa, pengiriman sms tagihan, confirmasi order barang, confirmasi registrasi di aplikasi tertentu, dll.

Sedangkan Gammu yaitu sebuah aplikasi cross-platform yang digunakan untuk menjebatani / megkomunikasikan antara database SMS Gateway dengan SMS Device/ Modem. Gammu bertugas menjebatani antara komputer dengan sms device/modem. Saat ada sms masuk ke sms device, maka gamu akan memindahkannya ke inbox dalam database aplikasi sms gateway. Sebaliknya saat aplikasi sms gateway mengirimkan sms ke dalam database outbox, maka gammu akan meneruskannya ke nomor tujuan melalu sms device/modem.

Berikut Langkah-langkahnya

Installasi Gammu dan Seting Device

# Siapkan Modem + Simcard yang ada quota sms nya
# Untuk cek modem yang suport gammu bisa di lihat di https://wammu.eu/phones/
# Setelah itu extrak / install file source gamu yang telah anda download ke folder yang anda tentukan misal  di c:/gammu
# Cari file gammurc dan smsdrc , copy ke dalam folder c:/gammu/bin
# Cek modem yang anda gunakan di Device manager windows, menggunakan port com berpa.
    

# Edit file gammurc seperti ini
 [gammu]
device = com4:
connection = at19200
   note: device = com4, port modem yang saya gunakan.

Buka cmd run as administrator
# Masuk ke direktori gammu/bin : cd /gammu/bin
# Ketik perintah  : gammu --identify


  # Setelah itu kita coba kirim pesan dengan perintah
     gammu --sendsms text 0899xxxxx  enter 
     masukan pesan yang akan dikirim, kemudian tekan CTRL+Z untuk proses kirim


# Cek pesan telah terkirim ke nomer penerima atau belum, jika sudah seting device modem sudah benar
# gammu version : untuk melihat versi gamu yang digunakan

Integrasikan  Gammu dengan  Database Mysql

# Edit file smsdrc di folder C:/gammu/bin
   [gammu]
# isikan no port di bawah ini
port = com4:
# isikan jenis connection di bawah ini
connection = at19200
[smsd]
service = mysql
logfile = gammulog
debuglevel = 0
phoneid = modem1
commtimeout = 30
sendtimeout = 600
send = yes
receive = yes
checksecurity = 0
#PIN = 1234
# -----------------------------
# Konfigurasi koneksi ke MySQL
# -----------------------------
pc = localhost
user = root
password =
database = gammu
# Cari file mysql.sql dari source gammu yang telah diwonload 
# Import file sql gamu, kedalam database mysql komputer anda, di sisni saya menggunakan XAMPP
# Restart Service gammu terlebih dahulu, setelah itu kita coba test kirim sms dari web browser.

Kirim Pesan Melalui Web Browser dengan Aplikasi PHP

Setelah langkah -langkah di atas kita bisa mencoba kirim sms via web dengan aplikasi php yang sudah di itegrasikan dengan gammu yang di buat oleh saudara Rosihan Ari (http://blog.rosihanari.net) , dan pengguannya sangatlah mudah. untuk project bisa anda download di sini download gammu_php

# Extrak file tersebut, taruh di Webserver local anda
# Buka http://localhost/gammu

# Klik langkah 1; untuk seting database.
# Untuk username mysql dan password mysql sesuaikan dengan server anda
# Langkah 2; seting modem dan sesuaikan port modem yang anda gunakan, kemudian simpan

# Klik cek koneksi dan buat service nya.
# Jika klik Buat Service error, anda bis buat service secara manual dengan cara;    masuk ke di rektori project anda  melalui cmd run as administrator, kemudian ketikan perintah    gammu-smsd -c smsdr1 - n modemku -i 
# Untuk menghapus service gamu yang sebelumnya di buat dengan perintah : sc delete "nama service" 
# Setelah service berhasil di buat buka run services.msc cari service gammu tersebut, trus start
 

# dan yang terakhir kita masuk ke langkah 3 untuk test kirim pesan dari form php


Demikian tutorial instalasi dan configurasi gammu di OS windows, dan berikutnya akan saya buatkan tutorial lanjutan untuk instalasi dan configurasi gammu di OS Linux. semoga artikel ini bermanfaat bagi pembaca. 

Salam - NEXTER -


Cara Mengubah IP Address di Ubuntu Server

Untuk mengubah sebuah IP Address di OS Ubuntu Server memang berbeda dengan Ubuntu Desktop. apalagi dengan OS windows, sangatlah berbeda. Dan bagi mereka yang belum terbiasa pasti akan kebingunan karena Ubuntu Server berbasis text / atau tanpa antarmuka desktop / CLI ( command-line interface).

Berikut Cara Mengubah IP Address di Ubuntu Server

# Pastikan anda telah login ke server anda, bisa langsung dari monitor server atau via remote ssh
# Jika Via remote, buka aplikasi putty, masukan ip address server 


# klik Open, 

# kemudian masukan user dan password server anda;
# Jika langsung dari monitor server anda langsung ketikan user dan passwordnya saja.

# ketikan perintah sudo su , kemudian enter dan masukan password kembali
# ketikan perintah nano /etc/network/interfaces , kemudian enter
# ganti yang saya beri garis bawah merah tersebut sesuai dengan ip address anda; misal
   address 192.168.1.30
   netmask 255.255.255.0
   network 192.168.1.0
   broadcast 192.168.1.255
   gateway 192.168.1.1
   dns-nameservers 192.168.1.1

# CTRL + X , Y - ENTER
# kemudian restart network anda dengan perintah /etc/init.d/networking restart 
# Setelah restart network tidak ada peringatan error,  anda telah berhasil mengubah ip address server 
# coba test ping gateway network anda ping 192.168.1.1,  maka akan tampil seperti ini
# CTRL + C untuk close proses
# sudo shutdown -h now (Perintah untuk mematikan server)
# reboot (Perintah untuk restart komputer server)


Seting Mysql Server agar bisa di akses dari luar localhost

Berikut ini cara seting Mysql server yang telah di install agar bisa di akses dari luar host atau komputer lain dalam satu jaringan :
1. Edit file my.cnf ; /ect/mysql/my.conf
    cari baris 
    # bind-address  = 127.0.0.1 
    # atau bind-address = ip server sebelumnya
2. Ubah bind-address default menjadi ; bind-address = ip server
    misal bind-address  = 192.168.1.30
3. Simpan CTRL+X, Y - ENTER 
4. Restart service Mysql server
    # /etc/ini.d/mysql restart
   jika tidak ada keterangan error, setingan anda benar.

Demikian tutorial dari saya semonga bermanfaat, jika anda ada permintaan untuk tutorial lainnya bisa contak saya di menu kontak yang tersidia.


Perintah Dasar Konfigurasi Router/Switch Cisco (CLI Cisco IOS)




Menampilkan Jam dan tanggal
Switch>show clock detail
Mengganti tanggal/jam
Switch#clock set hh:mm:ss  dd:mm:yyyy
Switch#clock set 15:28:10 22 Jun 2016
Menampilkan versi IOS
Switch>show version
Menampilkan perintah sebelumnya
Switch>show history
Untuk menampilkan satu-persatu perintah yang sudah diketikkan terlebih dahulu, gunakan tombol panah atas atau tombol panah bawah.
Menampilkan kemungkinan perintah
Switch>di?
akan menampilkan perintah disconnect
Switch>e?akan menampilkan perintah enable   exit
Menampilkan manual help
Switch>show ?
Switch>show users
Switch>show sessions
Switch>ping ?
Switch>traceroute ?
Menampilkan informasi interface
Switch menyediakan 12 atau 24 port. Setiap port dapat dipandang seperti sebuah interface. Masing-masing interface diberi nama sebagai : FastEthernet 0/1, FastEthernet 0/2, dan seterusnya sampai jumlah maksimal port yang tersedia.
Switch>show interfaces
Switch>show interfaces FastEthernet 0/1
Switch>show interfaces Fa 0/1
Switch>sh int Fa0/1
Switch>sh int F0/1
switch>sh in f0/1
Menampilkan CDP (Cisco Discovery Protocol)
Merupakan protokol yang digunakan untuk komunikasi antar perangkat cisco
switch>show cdp
Menampilkan informasi terminal
switch>show terminal
Memasuki privileged EXEC mode
untuk pindah ke mode privileged atau mode admin atau mode root di linux yang ditunjukkan dengan tanda #
switch>enableJika ingin kembali ke user EXEC mode ketikkan
switch>disable atau
switch>exit
Untuk masuk ketingkat Global
Switch#config t
Switch(config)#
Membuat Banner
Switch> enable
Switch#config t
Switch(config)#Banner MOTD “Cisco sys”
Switch(config)#Exit
Switch#logout
Menampilkan running configuration
switch>enable
switch#show running-config
Running-configuration disimpan sementara di RAM. Jika switch dimatikan maka semua informasi running-configuration akan terhapus
Menampilkan startup configuration
switch>enable atau bisa dengan mengetikan en
switch#show startup-config
Menentukan Jam dan tanggal
switch>enable
switch#clock set 12:20:20 5 october 2012
switch#show clock
Menentukan password mode privileged
Yaitu pembuatan password pada saat user biasa akan masuk ke mode privileged
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#enable password TIDAKDIENKRIPSI
Switch(config)#enable secret DIENKRIPSI
Switch(config)#^Z
%SYS-5-CONFIG_I: Configured from console by console
Switch#disable
Switch>enable
Password:
Menentukan password console
Password console digunakan untuk membatasi akses via port console atau via aplikasi emaulation seperti HyperTerminal
Switch>enable
Switch#configure termin
Switch#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#line console 0
Switch(config-line)#password passwordCONSOLE
Switch(config-line)#login
Switch(config-line)#^Z
Switch#disable
Switch>exit
Press RETURN to get started.
User Access Verification
Password:
Menentukan password telnet
Switch>en
Switch#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#line vty 0 15
Switch(config-line)#password passwordTELNET
Switch(config-line)#login
Switch(config-line)#^Z
Switch#disable
Switch>exit
Menentukan password AUX
Switch(config)#line aux 0
Switch(config-line)#password passwordAUX
Switch(config-line)#login
Switch(config)#^Z
Switch#disable
Switch#exit
* nomor – nomor diatas adalah merupakan port yang diberi nomor, misalkan sebuah port console yang diberi nomor 0, sebuah port aux yang diberi nomor 0 dan 16 buah VTY yang diberi nomor 0 s/d 15
Menentukan hostname 
Switch>en
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname Catalyst
Catalyst(config)#^Z
Catalyst#
Mengganti hostname
Switch>enable
Switch#config  t
Switch(config)#hostname budidarma
Switch(config)#exit
Switch#logout
Mereboot switch
Switch#reboot
Menyimpan hasil konfigurasi
Semua perintah yang kita ketikkan itu disimpan dalam memory sementara(RAM), jadi sewaktu switch atau Switch direboot maka konfigurasi akan hilang, untuk itu disarankan agar kita menyimpan konfigurasi yang sedang dilakukan(copy dari ram ke nvram)
Catalyst#copy running-config startup-config (copy dari ram ke nvram)
ATAU
Catalyst#wr
ATAU
Catalyst#copy running-config tftp 
Catalyst#show startup-config
Catalyst#copy startup-config running-config (copy dari nvram ke ram)
Menghapus startup configuration
Catalyst#erase startup-config
Catalyst#show startup-config
Catalyst#reload
File Image IOS
Switch#show flash
Switch#dir flash
File system configuration
Switch#show boot
Menggubah mode full duplex
Switch>en
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface fa 0/1
Switch(config-if)#duplex full
Switch(config-if)#^Z
Switch#show interfaces
Menggubah Speed
Beberapa tipe switch mendukung speed 10 Mbps dan 100 Mbps. Kita dapat menggubah speed tersebut
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface fa 0/1
Switch(config-if)#speed 10 atau 100
Menentukan IP address interface
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface vlan1
Switch(config-if)#ip address 192.168.10.1 255.255.255.0
Switch(config-if)#no shutdown untuk menenable/meng-up interface
Untuk me-reset suatu fungsi
Switch(config)#Clear
Membuat password console
Switch>enable
Switch#config t
Switch(config)#line console 0
Switch(config-line)#password 123switch
Switch(config-line)#login
Switch(config-line)#exit
Switch(config)#exit
Switch#logout
Mengaktifkan VLAN
Switch>enable
Switch#config t
Switch(config)#interface Vlan 100
Switch(config-if)#description name lab-1
Switch(config-if)#no shutdown
Switch(config-if)#exit
Membuat VLAN
Switch>enable
Switch#Vlan Database
Switch(Vlan)#Vlan 100  name Lab-1
Switch(Vlan)#Vlan 500  name Lab-2
Switch(Vlan)#exit
Menampilkan VLAN
Switch#Show Vlan
Mensetting Port pada VLAN
Switch>enable
Switch#config t
Switch(config)#interface FA 0/1
Switch(config-if)#switchport access Vlan 100
Switch(config-if)#no shutdown
Switch(config-if)#exit
Mensetting IP Address Pada VLAN
Switch>enable
Switch#config t
Switch(config)#interface Vlan 100
Switch(config-if)#IP Address 10.10.10.249  255.255.255.248
Menyimpan Configurasi
Switch>enable
Switch#copy running-config  startup-config
Enter untuk OK
Keluar dari Switch
         Switch#disable
Keluar dari Console
         Switch#logout
Help command
Switch#?
bisa dipakai untuk melihat help command tertentu misal kita pengin tahu perintah yang depannya c
Switch#c?
atau kila kita lupa sintaks utuh nya seperti apa
Switch#clock ?
Hot keys:
Kursor pindah ke awal baris : Ctrl + A
Kursor ke akhir baris : Ctrl + E
Mundur 1 kata : Esc + B
Mundur 1 karakter : Ctrl + B
Maju 1 karakter : Ctrl + F
Menghapus : Backspace
Melihat perintah sebelumnya : Up arrow atau Ctrl + P
Encrypting Password
         Switch(config)#service password-encryption
         Switch(config)#^z
Melihat, menyimpan dan menghapus konfigurasi
Switch#sh run (melihat)
         Switch#copy run start (menyimpan)
         Switch#erase startup-config (menghapus)
Pendataan VLAN ID yang terhubung
Switch#vlan database
Switch(vlan)#vlan 10 name keuangan
Switch(vlan)#vlan 20 name produksi
Switch(vlan)#vlan 40 name HRD
Switch(vlan)#vlan 50 name IT
Switch(vlan)#exit
Switch#
Pemberian alamat pada interface dari switch
Switch#configure terminal
Switch(config)#interface fastethernet0/1
Switch(config-if)#switchport access vlan 10
Switch(config)#interface fastethernet0/2
Switch(config-if)#switchport access vlan 10
Switch(config)#interface fastethernet0/3
Switch(config-if)#switchport access vlan 20
Switch(config)#interface fastethernet0/4
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Config-register adalah perintah unutk menentukan dari mana Switch akan memulai sistem boot secara otomatis.
Switch(config)#config-register 0x2142 untuk masuk ke ROM monitor mode
Switch(config)#config-register 0x0101 untuk boot dari ROM
Switch(config)#config-register 0x2102 untuk boot dari NVRAM
VTY password: untuk membuat password untuk akses dengan telnet ke Switch
Switch(config)#line vty 0 4
Switch(config-line)#login
Switch(config-line)#password kunci untuk membuat password bernama kunci untuk mengakses Switch lewat virtual terminal

Encapsulation : berguna jika ingin menerapkan suatu jenis protokol WAN. Contohnya
point-to-point protocol (ppp) ke suatu interface, misalnya interface serial0, maka setelah masuk ke interface configuration mode, kemudian mengetik perintah encapsulation seperti berikut :
Switch(config-if)#encapsulation ppp
Disamping ppp, ada berbagai macam encapsulation yang dapat digunakan oleh Cisco Switch sebagai berikut :
Switch(config-if)#encapsulation ?
Atm-dxi ATM-DXI encapsulation
Bstun Block serial tunneling (BSTUN)
Frame-relay Frame relay network
Hdlc serial hdlc synchronous
Lapb LAPB (X.25 level 2)
Ppp Point to point protocol
Sdlc SDLC
Sdlc-primary SDLC (primary)
Sdlc-secondary SDCL (secondary)
Smds switched Megabit Data Service (SMDS)
Stun serial tunneling (STUN)
X25 x.25
Dalam percobaan yang telah dilakukan diketahui bahwa untuk menghubungkan antar Switch melalui hubungan serial diperlukan sinkronisasi semua aspek baik bandwidth, clock rate maupun jenis encapsulasi yang digunakan. Pada percobaan yang telah dilakukan menggunakan jenis encapsulasi hdlc, clock rate 64000 dan bandwidth 56
IP routing selalu diterapkan (enable) untuk Cisco Switch. Untuk menerapkan IP ke suatu interface, ketik perintah berikut dari configuration interface mode:
Switch(config-if)#IP address <ip address> <subnet mask>
Sedangkan IP routing statis dapat diubah dengan perintah :
Switch(config)#ip route <network destination id> <subnet mask>
<default gateway>
Dimana :
Network destination ID adalah alamat jaringan yang dituju. Subnet mask adalah subnet
mask jaringan yang dituju.
Default gateway adalah IP address dari gateway, biasanya IP address Switch yang berhubugan langsung.
Mengkonfigurasi Switch Default Gateway
Switch(config)#ip default-gateway {ip address}
contoh:
Switch(config)#ip default-gateway 172.20.137.1
Menampilkan status Initial Startup Switch
Switch#show version
Menampilkan konfigurasi dari sistem hardware, versi software, nama dan file sumber konfigurasi, dan boot images
Menampilkan file konfigurasi yang sedang aktif dari switch
Switch#show running-configuration
Menampilkan statistik dari semua konfigurasi interfaces pada switch
Switch#show interfaces
Menampilkan alamat IP,subnet mask, dan default gateway
Switch#show ip
Menampilkan running configurasi
Switch#show running-configuration
Building configuration…
Current configuration:
hostname “sayid”
ip address 10.1.1.33 255.255.255.0
ip default-gateway 10.3.3.3
interface Ethernet 0/1
<text omitted>
interface Ethernet 0/12
Interface Ethernet 0/25
interface FastEthernet 0/26
interface FastEthernet 0/27
Konfigurasi IP Address dan interface sebagai link trunk ke interface Switch
Switch#conf t
Memberi nama interface
Switch(config-if)#description TRUNK-SWITCH-TO-SWITCH-A
Membuat interface menjadi trunk link
Switch(config-if)# switchport mode trunk
Membuat semua vlan di allow di interface trunk
Switch(config-if)# switchport trunk allowed vlan all
Memberikan ip dan mengaktifkan vlan management switch yaitu vlan 1
Switch(config)#interface Vlan1
Switch(config)#description MANAGEMENT-VLAN
Switch(config-if)#ip address 192.168.1.2 255.255.255.0
Membuat routing switch ke arah Switch
Switch(config)#ip default gateway 192.168.1.1
Membagi Vlan dan segemtn ip per interface switch
Vlan yang di gunakan yaitu vlan 10 untuk ip segment 192.168.10.0/24 dan vlan 20 untuk 192.168.20.0/24
Switch(config)#interface fastEthernet 0/1
Membuat interface menjadi acces link
Switch(config-if)# switchport mode acces
Configure the virtual line password. Password virtual line berguna untuk mengatur hak akses control Telnet ke Switch.
Sebagai contoh password yang digunakan adalah:cisco
Switch(config-line)# line vty 0 4
Switch(config-line)# password cisco
Switch(config-line)# login
Switch(config)#service password-encryption Untuk melakukan enkripsi password
Apabila kita salah mengetikkan perintah IOS akan mencoba untuk menampikan pesan error atau peringata. Salah satunya tanda ‘^’ yang menunjukkan error dalam penulisan.
Code:
Switch>sh confikur
^
% Invalid input detected at ‘^’ mark
Menampilkan perintah sebelumnya
Code:
Switch>show history
Manampilkan kemungkinan perintah
Code:
Switch>di?
disconnect
Menampilkan manual help
Code:
Switch>?
Switch?sh ?
Untuk menghapus hasil konfigurasi yang telah tersimpan
Code:
hal ini biasanya di lakukan untuk merubah settingan apabila ada kesalahan di config
Switch>enable
Switch#erase startup-config

untuk melihat config sebelumnya
Switch#show startup-configdan reset Switchnya
Switch#reload
Show controllers serial – menampilkan informasi khusus hardware interface. Perintah ini harus di-set termasuk nomor port/slot dari interface serial.
Contoh :
Switch#show controllers serial 0/1
Perintah yang digunakan untuk seting clock rate sebagai berikut:
Switch(config)#interface serial 0/0
Switch(config-if)#clock rate 56000
Switch(config-if)#no shutdown
Sebelum meng-install Csco IOS ke Switch, cek dulu apakah RAM dan flash yang dibutuhkan untuk install IOS tersebut memenuhi. Untuk melihat ukuran RAM dapat digunakan perintah show version. Seperti contoh tampilan di bawah ini.
Switch>show flash
…<output omitted>…
[12655376 bytes used, 4121840 available, 16777216 total] 16384K bytes of processor board System flash (Read/Write)
Menampilkan Setup Mode
Switch#Setup
Membuka koneksi Telnet
Switch>telnet
Buat Database VLAN pada Switch.
Switch>enable
Switch#vlan
Switch#vlan database
Switch(vlan)#vlan 2 name guest
VLAN 2 added:
Name: guest
Untuk memudahan pemberian IP address pada host tiap-tiap VLAN ada baiknya kita membuat DHCP server, dan pada contoh ini kita akan menggunakan IP 222.124.194.11 sebagai DNS server
Switch(config)#ip dhcp pool vlan2
Switch(dhcp-config)#default-Switch 192.168.0.1
Switch(dhcp-config)#dns-server 222.124.194.11
Switch(dhcp-config)#network 192.168.0.0 255.255.255.0
Switch(dhcp-config)#exit
Buat default routing yang berfungsi sebagai “the last resort” terhadap tujuan packet dalam menuju alamat yang tidak terdapat pada routing tabel, sehingga packet tidak di-dischard atau dibuang dari network.
Switch(config)#ip route 0.0.0.0 0.0.0.0 222.124.194.1
Buat NAT sehingga IP private yang berada pada VLAN bisa ditranlasi menuju IP Public, masuk ke interface gigabitEthernet 0/1 dan setting sebgai NAT Outside, kemudian masuk ke tiap-tiap Interface VLAN yang sudah kita buat dan set sebagai NAT Inside.
Switch(config)#interface gigabitEthernet 0/1
Switch(config-if)#ip nat outside
Switch(config-if)#exit
Kemudian buat aturan NAT dan jangan lupa untuk mengatur access-list agar mengizinkan packet untuk lewat, perhatikan juga nomor aturan NAT dan access-list keduanya harus mempunya nomor yang sama, jadi kalau aturan NAT-nya menggunakan nomor 1 maka pada access-list juga harus menggunakan nomor 1.
Switch(config)#ip nat inside source list 1 interface gigabitEthernet 0/1 overload
Switch(config)#access-list 1 permit any
Switch(config)#
Kembali ke Privilege Mode dan simpan hasil konfigurasian
Switch(config)#exit
Switch#copy running-config startup-config
Switch#
Menghapus file
Switch>enable
Switch#delete
Membuat direktori baru
Switch>enable
Switch#mkdir
Memutuskan koneksi jaringan yang ada
Switch>enable
Switch#disconnect
Konfigurasi Class-map
Switch>enable
Switch#configure terminal
Switch(config)#class-map
Menentukan konfigurasi register
Switch>enable
Switch#configure terminal
Switch(config)#config-register
Enkripsi Modul
Switch>enable
Switch#configure terminal
Switch(config)#crypto
Perintah cisco untuk melihat konfigurasi ip route yang sudah ada / terdaftar
Core-Switch#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route
S       10.0.2.0 [1/0] via 172.20.114.86
S       10.0.3.0 [1/0] via 172.20.140.11
S       10.0.0.0 [1/0] via 172.20.114.85
S       10.0.1.0 [1/0] via 172.20.114.85
Perintah cisco untuk menghapus iproute static
misal : S 10.0.3.0 [1/0] via 172.20.140.10
Core-Switch#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Core-Switch(config)#no ip route 10.0.3.0 255.255.255.0 172.20.140.10
Core-Switch(config)#^Z
Perintah cisco untuk menambah iproute static,misal : 10.0.3.0 255.255.255.0 172.20.114.84
Core-Switch#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Core-Switch(config)#ip route 10.0.3.0 255.255.255.0 172.20.114.84
Core-Switch(config)#^Z
Jangan lupa untuk menyimpan konfigurasinya
Core-Switch#copy running-config startup-config
Core-Switch#exit
Perintah berikut adalah command line di switch cisco 2950 untuk mengaktifkan konfigurasi static MAC Address, dan sebelumnya catat MAC Address di computer A dalam study case ini adalah 00D0.972E.917C
Switch>en
Switch#config t
Switch(config)#mac-address-table static 00D0.972E.917C vlan 1 int f0/2
Switch(config-if)#^Z
Selanjutnya aktifkan perintah konfigurasi port security dalam study case ini adalah interface f0/5
Switch#
Switch>en
Switch#config t
Switch(config)#int f0/5
Switch(config-if)#switchport mode access
Switch(config-if)#switchport port-security
Switch(config-if)#switchport port-security mac-address sticky
Switch(config-if)#switchport port-security max 4
Switch(config-if)#switchport port-security violation shut down
Switch(config-if)#^Z
Artinya command line /perintah diatas adalah port dari interface f0/5 hanya bisa di pakai maksimal 4 host atau empat computer.Jika seandainya kita tambahkan satu computer lagi di hub D-link maka interface f0/5 akan langsung state to down atau mati.dan semua computer yang terhubung dengan interface f0/5 tidak akan bisa terkoneksi dengan computer A atau computer server, untuk mengaktifkan lagi interface f0/5 cabut computer yang terhubung ke hub tadi, sehingga computer hanya terhubung 4 host via int f0/5
Mengkonfigurasi konsol line untuk membutuhkan password saat loginSwitch(config) # line console 0
Switch(config-line) # password cisco123
Switch(config-line) # login
Mengatur vty password untuk cisco123
Switch (config-line) # line vty 0 15
Switch (config-line) # password cisco123
Mengkonfigurasi vty untuk membutuhkan password saat login:Switch (config-line) # login
Switch (config-line) # end
Menampilkan CDP
Switch> show cdp
Perintah diatas digunakan untuk menampilkan informasi tentang CDP (Cisco Discovery Protocol) yang digunakan untuk komunikasi antar perangkat Cisco.
Menghapus startup config
Switch# erase startup-config
Menguji koneksi
Switch# ping 192.168.0.254
Unutk menguji konkesi prinsipnya sama dengan melakukan ping ke destinantion host.
Assigning Port VLAN
Switch(config)# interface fa0/1
Switch(config-if)# switchport mode access
Switch(cofnig-if)# switchport access Vlan 2
Setting Port-Speed dan Link-Mode
Switch#configure terminal
Switch(config)#interface nama-port (misal : interface fast ethernet 0/1)
Switch(config-if)#speed 100
Switch(config-if)#duplex full
Switch#configure terminal
Switch(config)#interface nama-port
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan nama-vlan
Switch#configure terminal
Switch(config)#interface nama-port
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan nama-vlan
Menghapus Semua Konfigurasi
Switch#erase startup-config
Switch#dir
Switch#delete flash:vlan.dat
Switch#dir
Switch#reload
Menyimpan Semua Configurasi
Switch#write memory
Switch#write mem

Pemrograman

More »

Networking

More »